Requirements

Requirements for running the API locally
Mandatory
Optional

Additional requirements for running the API in docker containers
Mandatory
  • Docker Desktop(for Windows): Version 2.1.0.1 (37199) or superior
    • Enable:
      • Kubernetes 1.14+
      • Linux container (Not windows containers)
    • Docker Engine 19.03.1+ (provided with docker)
    • WSL (Windows Subsystem for Linux: recommended v1, v2 is still in preview and has not been tested) (provided with docker)
      • For running build, test and deployment scripts targeting Linux environment
    • kubectl v1.14+ (provided with docker)

Additional requirements for running the API in a kubernetes cluster
  • NGINX ingress controller
    • Install the ingress controller in you local cluster.
    • Make sure you follow the process for Bare Metal deployment described here.
note

The current version of Amido Stacks is a template for .NET Core 3.1 (Current LTS, recommended).